“Static RTMP” feature – beta – available upon request

Home Forums Beta and Experimental Features “Static RTMP” feature – beta – available upon request

New Topic
Viewing 15 posts - 31 through 45 (of 45 total)
  • Author
    Posts
  • #130277
    voyager
    Participant

    I have definitely confirmed that when using both the Low Latency and the Static RTMP features, I have to go into my WordPress site editor and start a live event under WpStream/Channels. I do not have to press any of the ‘Go Live…’ buttons, just the ‘Start Live Event’ button. If I do this, I can then go to OBS on any other computer, start the stream and then on any other computer go to the WordPress site and page (assigned to the stream with the short code) and display the stream.

    I think the only issue standing in the way of the two beta’s working smoothly together is to get the stream to start without having to edit the WordPress site. Somehow through OBS, with it’s static server and stream key data, start the live event when OBS connects to Wpstream servers instead of having to run through the WpStream plugin on WordPress.

    #130426
    Christina
    Moderator

    To confirm,

    1. broadcasting to a channel’s ‘Static RTMP’ address will ALWAYS start a new event if one is not currently active

    2. the 2 beta features are known to work together for at least a couple customers, however not guaranteed to work universally; if you can reproduce your use case on a ‘clean’ wordpress we may be able to step in and troubleshoot

    #130635
    rickgutridge
    Participant

    Not sure what you mean by a “clean wordpress”. Please clarify.

    #130661
    Christina
    Moderator

    Hey Rick,

    By ‘clean’ I mean a wordpress with just the essential plugin and settings, so as to rule out conflicts as a factor. Also no caching of any kind. Also a default theme like twentytwenty.

    #130716
    voyager
    Participant

    Christina,
    Thanks for the clarification. I’m pretty clean now, but I’m not using the twentytwenty theme. Perhaps that’s where the conflict is buried. I tried what I believed was a sure-fire way to start things up and it didn’t work as I had hoped. Still some misunderstanding/conflict in my process. I’ll keep working it and fill you in on issues and/or solutions.

    Thanks –
    Rick

    #131049
    Beatrice
    Moderator

    Hello Rick,

    Please let us know if you were able to pin-point the issue or if you are still facing issues.

    Best

    #131067
    james-8940
    Participant

    So I followed the general instructions sent to me when I inquired. I thought it was easy to set up and so far working well. I will report any issues after additional testing. By the way I set up two static channels just to test.

    #131137
    Beatrice
    Moderator

    Hello James,

    Good to hear that! Do not hesitate to let us know if you see any cause for concern or have any questions.

    Best regards

    #136127
    Grace Church
    Participant

    Hi,

    We followed the instructions to get the static url and stream key. When I use the key and url, we are able to stream from our stem mini, but after starting the livestream, the stream says that the stream was paused.

    In WordPress, I cannot update the key or url and they are the non-static values. Not sure if this is causing the issue.

    Thanks in advance for your help

    #136368
    Christina
    Moderator

    @tomskasa

    Please send the ‘stem mini’ configuration in an email to support@wpstream.net, we’ll attempt to troubleshoot the setup.

    #137041
    Grace Church
    Participant

    Here is the config in the streaming.xml for the ATEM

    <servers>
    <server>
    <name>Bluehost</name>
    <url>rtmp://ingest.live.streamer.wpstream.net/wpstream/23258-2634-01c78c36b9c10aae</url>
    </server>
    </servers>

    Here is the config in the ATEM switcher.xml for the ATEM
    <LiveStream serviceName=”Grace Church” url=”rtmp://ingest.live.streamer.wpstream.net:1935/wpstream/” key=”23258-2634-01c78c36b9c10aae”>
    <Credentials username=”” password=””/>
    <bitrate low=”6000000″ high=”9000000″/>
    <audioBitrate low=”128000″ high=”128000″/>
    </LiveStream>

    Streaming from the ATEM works, connecting to the new server, I do not get an error streaming. However, when you go to the site, you dont see the stream and see the error. I wonder if the database entries need to be modified to point to the new stream as you cannot change the url or key in wordpress.

    #137286
    Christina
    Moderator

    @tomskasa

    The configuration looks correct
    Please review the email instructions, it looks to us like you did not first start the channel from the wordpress, this is required.

    #140177
    Grace Church
    Participant

    I did as you suggested and started the stream first. That did not work. My guess is that there is a DB entry that points WP to the stream. Although I can stream to it via the ATEM mini, the WP Livestream cannot find the livestream…..

    #140271
    Beatrice
    Moderator

    Hi Grace,

    Sorry to hear that you are still having issues streaming with custom RTMP. Please answer the questions below since we need to know more details about your experience to narrow out certain variables:

    – Have you attempted to stream through the browser or through OBS?
    – Have you attempted to stream normally (without Static RTMP) and does that work for you?
    – Are you able to send a link to the affected page?

    Looking forward to helping you solve this.

    #140787
    dsmithknowles72
    Participant

    Hi team,

    This feature has been working *great* for the past 18 months. This weekend, it stopped working and I had to scramble a bit to get the channel live on my Word Press site by using the “Go live with external browser”. I went back through instructions I got when this feature was first released and made sure my setting where right according to the server/key pair returned by the API. (I use Restream, so I used the “generic” values in the response). I tried streaming directly from restream.io to the channel but no luck. When I use the dynamic values from the plugin (values given by clicking the “Go live from external browser” button), it works fine.

    I tried using this as the server value rtmp://ingest.live.streamer.wpstream.net:1935/wpstream (and my stream key). I also tried streaming from OBS using the server/key value from the api but no luck there either.

    Not a big deal to configure manually, but am wondering what happened to this great feature? Anything else I can check? Like I said, this has been working perfectly up until this week.

    Thanks!
    Diane

Viewing 15 posts - 31 through 45 (of 45 total)
  • You must be logged in to reply to this topic.