WpStream Buttons

Home Forums WpStream Plugin Plugin Feature Requests WpStream Buttons

New Topic
  • This topic has 1 reply, 2 voices, and was last updated 1 year ago by admin.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #69434
    vision
    Participant

    vision <vision@alicemedia.ca>

    Apr 29, 2020, 2:37 AM (1 day ago)

    to office

    Hello,

    I’m using the WPStream WordPress Plugin along with a Family streaming package and I’m trying to let my users start broadcasting their own event from the frontend of the site.

    So far I used “WCFM – Frontend Manager for WooCommerce” to build the frontend and I import the “Broadcast to channel” from the backend with an iFrame.

    Only problem is I get the “Getting ready to stream” on loop forever. Can you givew me the code to import the “Broadcast to channel” on an frontend page?

    Can I copy the code from “event_list.php”?

    Thank you,

    Samuel Mainville

    #69443
    admin
    Keymaster

    Hi,
    Is a little hard to answer this without doing the actual code. I don’t think the iframe will work work because there are some ajax calls that may not “get out” of the iframe. Also there is a security measure that only let admins start the actual brodcasts.

    That being said i would do the things in the following way

    Locate the wpstream_live_stream_unit function- is in class_wpstream-admin.php class -(Attention is a method of a class not a simple function).
    Try to clone that function and use that . The function holds the code for the “start brodcast” action. If only admin are allowed to stream then it should work.
    If not then you need to disable that check (on your risk)
    – The ajax call that start is on admin_control.js http://prntscr.com/s8fz8p
    – the php function for that is in class-wpstream-live-api-connection.php http://prntscr.com/s8fzsr
    – the security check is at line 209 – if( !current_user_can(‘administrator’) ){…

    Thank you

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.